La última versión de VLC tiene un agujero de seguridad

Escrito por Adrián Crespo
Seguridad
0

Si ayer os hablábamos de vulnerabilidades en el protocolo UPnP y de una actualización falsa de Adobe Flash Player, esta vez no podemos dejar pasar por alto una vulnerabilidad que ha sido detectada en uno de los reproductores de audio y video, y que a día de hoy se encuentra entre uno de los más utilizados. VLC posee una vulnerabilidad en su última versión que podría permitir la ejecución de código de forma remota.

Han sido los propios desarrolladores del reproductor los que han dado a conocer esta vulnerabilidad que han descubierto ellos mismos y que podría provocar que en el ordenador del usuario se llevase a cabo la ejecución de un código utilizando como soporte el reproductor VLC.

La vulnerabilidad puede ser aprovechada mediante videos .ASF, aprovechando un fallo que se encuentra en la librería libasf_plugin.*. Como primer consejo, los desarrolladores han recomendado no llevar a cabo la reproducción de videos .ASF cuyo origen sea desconocido.

VLC_problema_seguridad

Eliminar la librería dinámica afectada

Desde VLC han recomendado llevar a cabo la eliminación de la librería \VLC\plugins\demux\libasf_plugin.dll en Windows,  para evitar que la vulnerabilidad pueda llegar a ser explotada. Los desarrolladores ya han puesto a disposición del usuario una versión nueva, que aunque todavía está en desarrollo, ya puede descargarse y evitar que esta vulnerabilidad sea utilizada por terceras personas para infectar el equipo por malware.

Los usuarios de MAC OS también pueden actualizar a la última versión para solucionar el mismo problema. Sin embargo, con respecto a los usuarios de Linux, parece ser que no ha habido indicios de que la versión para este sistema operativo esté afectada. A pesar de esto, los desarrolladores también se encuentran trabajando en una nueva versión.

Fuente | The H Security