Internet Explorer comienza a bloquear versiones antiguas de Java

Escrito por Adrián Crespo
Seguridad
0

Los problemas que han provocado complementos de navegadores que no estaban actualizados han sido numerosos y por este motivo los responsables de estos comenzaron a tomar medidas para evitar que estos puedan seguir provocando problemas. El turno es ahora para Microsoft y su navegador Internet Explorer, estrenando una función que permite el bloqueo de complementos ActiveX que se encuentren desactualizados.

Aunque la función se introdujo a mediados del mes de agosto, ha sido en el día de ayer cuando esta se activó de forma oficial. El funcionamiento es muy sencillo: cuando un usuario entra en una página web y se requiere un complemento ActiveX desactualizado se le notifica al usuario, advirtiéndole de qué complemento ha sido bloqueado y si quiere que siga bloqueado o permitir su ejecución al menos esta vez.

Después de todos los problemas que ha dado Java en los navegadores, este también estará sujeto a ser bloqueado y ya se dispone incluso de un listado de versiones que serán bloqueadas por Internet Explorer:

  • J2SE 1.4 y anteriores excepto update 43
  • J2SE 5.0 y anteriores excepto update 71
  • Java SE 6 y anteriores excepto update 81
  • Java SE 7 y anteriores excepto update 65
  • Java SE 8 y anteriores excepto update 11

La obtención de la lista de complementos a bloquear se hace gracias al uso de un fichero que se actualiza a diario y donde el navegador posee un listado con todos los complementos que están desactualizados y que son susceptibles a ser bloqueados.

Internet Explorer cómo funciona el bloqueo

El fichero al que anteriormente hemos hecho referencia se encuentra ubicado en los servidores de la propia compañía, y es el propio navegador el que solicita información cuando accede a una página web y detecta que es necesario hacer uso de un complemento.

Microsoft ha querido aclarar también el tema de la disponibilidad de esta función, afirmando que esta solo se encuentra disponible en Windows 7 SP1 y posteriores, encontrándose en versiones de Internet Explorer 8, 9, 10, y 11.

Una vez que se instale la actualización hecha pública en el día de ayer el navegador comenzará a bloquear todos aquellos complementos que se encuentren desactualizados y que puedan tener vulnerabilidades que pongan en peligro el equipo.

Fuente | Softpedia


Noticias relacionadas