Los equipos parcheados aún son vulnerables a Shellshock

Escrito por Adrián Crespo
Seguridad
0

Desde equipos NAS hasta servidores VPN, estos son dos de los afectados por esta vulnerabilidad y que todo parece indicar que aún lo siguen estando. Sería lógico hablar de esto si el propietario o responsables del servicio no hubiesen tomado las medidas pertinentes. Sin embargo, un grupo de científicos ha demostrado que los equipos que poseen actualizaciones para resolver la vulnerabilidad Shellshock aún estarían afectados.

Expertos en seguridad de la compañía Trend Micro han demostrado que el ataque puede reproducirse bajo unas condiciones muy concretas y a pesar de disponer de las actualizaciones que resolvían el problema instaladas. Según las simulaciones de la empresa de seguridad, la vulnerabilidad podría explotarse de nuevo con tan solo producirse un degradado de la versión del software instalada. Sin embargo, esto en la mayoría de los casos no resulta una tarea fácil.

Esta mecanismo estaría dedicado sobre todo a afectar a servidores, realizando desde la empresa una demostración con un script escrito en Python. Sin embargo, para realizar la instalación este debe llegar al servidor de alguna forma, siendo necesaria la existencia de alguna petición web para proceder en primer lugar a subir el script y posteriormente realizar la descarga de la versión de BASH vulnerables y su posterior instalación. De esta forma y gracias al degradado de la versión instalada, los ciberdelincuentes podrían llegar aprovechar la vulnerabilidad Shellshock.

Shellshock degradado de versión no vulnerable

Muchas veces una actualización no es la mejor solución, o al menos la definitiva

Expertos en seguridad han demostrado que bajo unas circunstancias concretas un atacante podría degradar el software de un equipo y restaurar problemas de seguridad que se habían solucionado. Esto ha sucedido con Shellshock pero añaden que también es aplicable a otras infecciones. Insisten en que sería necesario desarrollar nuevos sistemas que puedan proteger los equipos, como por ejemplo, una verificación de la versión de la actualización que se está instalando o el desarrollo de un módulo que sea capaz de comprobar los scripts que se están ejecutando y qué tarea están desempeñando en el sistema, evitando una ejecución no autorizada de una actualización.

Fuente | Softpedia