La vulnerabilidad SOP de Android permite hackear cuentas de Facebook

Escrito por Adrián Crespo
Android
0

La fragmentación del sistema operativo móvil de los de Mountain View se presenta como un problema a tener en cuenta. Las actualizaciones no llegan y estas son las únicas que pueden resolver problemas de seguridad detectados. El problema de seguridad SOP de Android afecta a dispositivos que utilicen versiones inferiores a la 4.4, siendo en la actualidad una gran cantidad de usuario y pudiendo permitir incluso el robo de cuentas de otros servicios, como por ejemplo Facebook.

Lo peor de todo esto es que han sido un grupo de investigadores de Trend Micro en colaboración con los responsables de seguridad de la red social los que han destapado que existe un número de cuentas que ya se han visto afectadas por esta vulnerabilidad que afecta al navegador por defecto que posee el sistema operativo de Google. Los ciberdelincuentes han publicado el metaexploit en páginas web, haciendo mucho más sencillo explotar esta vulnerabilidad en dicho navegador web.

SOP (del inglés Same Origin Policy) es un módulo que permite al usuario disfrutar de una navegación mucho más segura (o eso se creía) evitando que en una página se puedan cargar códigos que no pertenezcan a la fuente original. Sin embargo, este módulo está siendo objeto de un ataques XSS permitiendo la carga de scripts que están destinados a realizar el robo de los datos de los usuarios.

Los responsables de la red social en colaboración con Trend Micro han realizado una demostración de cómo se pueden realizar los ataques, utilizando en este caso la propia red social. Los atacantes pueden introducir un marco con un enlace y que este redirija al usuario hacia una página que no es propiedad de la red social y donde sin embargo se solicita el ingreso de las credenciales para acceder al contenido, produciéndose el robo de los datos introducidos.

SOP de Android sigue siendo vulnerable por culpa de los fabricantes

Exceptuando los dispositivos Nexus que dependen directamente de Google, el resto de dispositivos deben recibir actualizaciones por medio del fabricante y es este el que debe publicar dicha actualización. Tal y como sucede con bastante frecuencia, no compensa perder el tiempo en publicar actualizaciones para terminales móviles con más de un año y es por este motivo que a día de hoy más del 80% de los dispositivos son vulnerables y es más que probable que lo sigan siendo. La solución que los usuarios pueden tomar es la de instalar otro navegador y no utilizar el que el sistema operativo posee por defecto.

Fuente | The Hacker News