Solucionan varios errores detectados en WPA y WPA2 en Ubuntu

Escrito por Adrián Crespo
GNU Linux

La capacidad para solucionar problemas de seguridad en esta distribución Linux es bastante eficaz y una prueba de ello es la ristra de fallos que se han resuelto y que están asociados con WPA y WPA2. Según se ha precisado, el módulo wpa_supplicant de Ubuntu es principalmente el que se encuentra afectado.

Al parecer algunos fallos asociados podrían permitir que el módulo falle al recibir paquetes mal formados, afectando también a hostapd. Los responsables de la distro han actuado con rapidez y hoy han publicado la actualización que afecta a varias versiones. En resumen, estos fallos de seguridad solucionados permitirían la realización de un ataque de denegación de servicio.

Las vulnerabilidades resueltas han sido las siguientes:

  • CVE-2015-4141
  • CVE-2015-4142
  • CVE-2015-4143
  • CVE-2015-4144
  • CVE-2015-4145
  • CVE-2015-4146

Mientras que las versiones que han recibido la actualización que resuelve el problema son:

  • Ubuntu 15.04
  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Las distribuciones que no se han mencionado es porque no se encuentran dentro del periodo de soporte que establecen los responsables de esta, aunque hay que decir que los usuarios que se verán beneficiados por esta será prácticamente la totalidad existente hoy en día.

Para solucionar el problema los responsables de la distro aconsejan a los usuarios que deben actualizar el sistema utilizando sudo apt-get update. Tras la realización de los cambios será necesario reiniciar el equipo pero el problema quedaría resuelto.

wpa_supplicant no se encuentra únicamente en Ubuntu

Se trata de un módulo que podría considerarse una pieza del kernel de Linux, por lo que está presente en más distribuciones. Sin embargo, aún no se ha informado sobre la existencia del error más allá de esta distro. Podría considerarse como una buena señal para los usuarios del resto de distribuciones que estarían libres de los fallos detallados con anterioridad.

Por lo tanto, si quieres poner fin a estos problemas tienes dos opciones:

sudo apt-get update

o
sudo apt-get dist-upgrade

Fuente | Softpedia


Últimos análisis

Valoración RZ
8
Valoración RZ
9
Valoración RZ
9
Valoración RZ
10
Valoración RZ
9
Valoración RZ
10
Valoración RZ
7
Valoración RZ
9
Valoración RZ
10