Canonical soluciona 14 vulnerabilidades serias en Ubuntu 16.04 LTS

Escrito por Rubén Velasco

Ubuntu es el sistema operativo basado en Linux más utilizado, tanto entre usuarios domésticos como en servidores. Este sistema, desarrollado y mantenido por Canonical, igual que cualquier otro sistema operativo, debe contar con un mantenimiento frecuente de manera que los usuarios y servidores que lo utilizan puedan estar protegidos de cualquier fallo o vulnerabilidad que pueda aparecer para el mismo lanzando parches tanto para el núcleo como para el resto de componentes del sistema como el que la compañía ha lanzado recientemente.

Hace algunas horas, Canonical publicaba un boletín de seguridad de emergencia para todos los usuarios de Ubuntu 16.04 LTS (junto a las versiones 16.04.1 y 16.04.2), la versión de soporte extendido de este sistema operativo. Este nuevo parche de seguridad se centra en solucionar un total de 14 vulnerabilidades descubiertas para el sistema operativo.

Este nuevo parche de seguridad se ha enviado ya a los usuarios a través del Kernel Live Patch, la función que permite a los usuarios de Ubuntu actualizar su sistema operativo y aplicar parches en caliente, es decir, sin necesidad de reiniciar el sistema para que estos parches se apliquen correctamente.

De esta manera, la versión que se ha enviado a los usuarios es la Kernel Live Patch 4.4.0-71.92, versión centrada en solucionar los 14 fallos de seguridad que vamos a ver a continuación.

Vulnerabilidades solucionadas en el Kernel 4.4 de Ubuntu 16.04 LTS

La mayoría de estas vulnerabilidades llevan presentes en el sistema operativo desde 2016, siendo solo 3 fallos de seguridad nuevos registrados este mismo año. En detalle, estos fallos de seguridad son:

  • CVE-2016-5195, un fallo en el administrador de memoria de Linux puede permitir a un atacante local ganar privilegios dentro del sistema.
  • CVE-2016-7910, una vulnerabilidad que permite el uso de memoria después de liberarse puede permitir a un atacante local causar un DoS en el sistema o ganar privilegios dentro del mismo.
  • CVE-2016-7911, un fallo similar al anterior, pero localizado en la función sys_ioprio_get().
  • CVE-2016-7912, una vulnerabilidad en los controladores USB de todos los Kernel anteriores a la versión 4.5.3 puede permitir a un atacante ganar privilegios dentro del sistema accediendo a la estructura I/O después de una determinada llamada del sistema.
  • CVE-2016-7916, un fallo en la función procfs del Kernel puede permitir a un atacante local conseguir información sensible directamente desde la memoria del sistema.
  • CVE-2016-8399, una mala implementación del protocolo ICMP hace que no se comprueben correctamente las cabeceras de los paquetes, permitiendo a atacantes locales exponer información sensible de los sistemas afectados.
  • CVE-2016-8630, un fallo en la implementación de KVM puede hacer que un atacante cause una denegación de servicio en el sistema anfitrión desde una máquina virtual.
  • CVE-2016-8633, una mala implementación del controlador FireWire en el Kernel Linux puede generar un desbordamiento del búfer permitiendo a un atacante remoto ejecutar código aleatorio en el sistema con permisos de root.
  • CVE-2016-9191, un error en la implementación de sysctl que puede permitir a un atacante, incluso aunque este esté configurado sin privilegios, causar un ataque DoS.
  • CVE-2016-9555, un error en la validación de los paquetes SCTP puede permitir a un atacante remoto causar una denegación de servicio en un sistema vulnerable.
  • CVE-2016-9756, una mala implementación de KVM que puede generar un error al procesar ciertas instrucciones, permitiendo a un atacante local acceder a partes reservadas de la memoria.
  • CVE-2017-2583, un error en KVM hace que no se emulen correctamente ciertas instrucciones y puede permitir a un atacante local recuperar información privada del sistema.
  • CVE-2017-6074, un fallo en la implementación de DCCP que puede permitir a un atacante local causar un DoS en el sistema o permitirle ganar privilegios dentro de este.
  • CVE-2017-7308, un fallo en la implementación AF_PACKET que no valida correctamente el tamaño de algunos paquetes. Este fallo puede permitir que un atacante local cause un DoS (bloqueo del sistema).

Como podemos ver, salvo 2, el resto de vulnerabilidad solo pueden explotarse localmente, aunque no por ello debemos considerarlas como poco preocupantes. Todos estos fallos afectan por igual a las ramas “generic” y “low latency” del Kernel.

Como hemos dicho, estos fallos solo afectan a la versión 4.4 del Kernel Linux, por lo que si hemos instalado otra versión del Kernel en nuestro sistema operativo no tenemos de qué preocuparnos. Además, aunque gracias al Live Patch estos parches se aplican sin necesidad de reiniciar el sistema, Canonical recomienda a los usuarios instalar, si pueden, una versión más actualizada y reiniciar para arrancar el sistema ya con todo lo que la nueva versión ofrece.

¿Eres usuario de Ubuntu 16.04 LTS?

Fuente > Softpedia

Últimos análisis

Valoración RZ
9
Valoración RZ
8
Valoración RZ
8
Valoración RZ
8
Valoración RZ
8
Valoración RZ
10
Valoración RZ
8