Una vulnerabilidad en el firmware para chips Wi-Fi afecta a millones de dispositivos

Escrito por Javier Jiménez

En este artículo nos hacemos eco de una noticia que informa de una vulnerabilidad que afecta al firmware de una serie de chips Wi-Fi. Concretamente se trata de un conjunto de chips populares y que están dentro de una gran variedad de dispositivos. Están presentes en teléfonos móviles, ordenadores portátiles, routers, plataformas de juegos y en numerosos dispositivos de lo que se conoce como el Internet de las Cosas.

Millones de dispositivos afectados por una vulnerabilidad en el firmware del Wi-Fi

Esta vulnerabilidad ha sido descubierta por un grupo de investigadores de seguridad y afecta a ThreadX. Es el sistema operativo en tiempo real que es utilizado como firmware en millones de dispositivos en todo el mundo. Por este motivo esta vulnerabilidad es de gran importancia. Puede afectar a millones de usuarios en todo el planeta.

Estos investigadores de seguridad han explicado que un posible atacante podría explotar la vulnerabilidad del firmware ThreadX. Hicieron una prueba con un chip Wi-Fi instalado en un Marvell Avastar 88W8897. Lograron ejecutar el código malicioso sin la interacción del usuario.

No es casualidad que los investigadores de seguridad eligieran este chip en concreto. La razón es porque es muy popular y es utilizado en numerosos dispositivos en todo el mundo. Está presente en plataformas de videojuegos como Sony PlayStation 4 o xBox One. También en ordenadores portátiles, así como en dispositivos móviles de varias marcas populares.

Según indica uno de los investigadores de seguridad, han logrado identificar 4 problemas de corrupción de memoria en algunas partes del firmware. Una de estas vulnerabilidades puede activarse sin la interacción del usuario al realizar una búsqueda de redes.

Errores comunes al conectarnos a una red Wi-Fi

Envía paquetes Wi-Fi con formato incorrecto

La función de firmware para buscar nuevas redes Wi-Fi se inicia automáticamente cada cinco minutos. Lo que hace el atacante es enviar paquetes Wi-Fi con formato incorrecto a cualquier dispositivo que cuenten con este tipo de chips con la vulnerabilidad. Posteriormente solo tienen que esperar hasta que se inicie la función y desplegar código malicioso para controlar el dispositivo.

Informan que esta vulnerabilidad que afecta a ThreadX podría estar presente en más de 6.000 millones de dispositivos. Como vemos, puede afectar a muchos usuarios en todo el mundo.

Podemos acceder al informe completo de esta vulnerabilidad. Lógicamente el código de prueba de concepto no se ha publicado.

En definitiva, una importante vulnerabilidad afecta a miles de millones de dispositivos en todo el mundo. Concretamente afecta a los chips Wi-Fi que están dentro. Son muchos los tipos de dispositivos que pueden sufrir este problema.

Nuestra recomendación es siempre mantener los sistemas y dispositivos actualizados con la última versión. De esta forma podremos hacer frente a posibles problemas que pongan en riesgo la seguridad y el buen funcionamiento. A veces surgen vulnerabilidades que son resueltas por los propios fabricantes mediante parches y actualizaciones de seguridad. Especialmente hay que tener en cuenta estas medidas cuando se trata de dispositivos conectados a Internet.

En un artículo anterior explicamos cómo actualizar el firmware del router. Y es que este dispositivo es sin duda una pieza clave a la hora de navegar por la red.

Fuente > ZDNET