Nuevas vulnerabilidades en RouterOS de MikroTik, actualiza cuanto antes

Se han descubierto varias vulnerabilidades en las últimas versiones de firmware de RouterOS, el sistema operativo que incluyen los routers de MikroTik. En los últimos tiempos se han descubierto una gran cantidad de fallos de seguridad asociados a RouterOS y a los routers MikroTik, y en esta ocasión tenemos un total de 4 vulnerabilidades de criticidad alta, por lo que es recomendable que actualices tu router cuanto antes.

Fallos de seguridad descubiertos en RouterOS de MikroTik

El investigador de seguridad Jacob Baines, ha descubierto un total de cuatro vulnerabilidades graves, en las que un atacante remoto no autenticado, podría acceder, modificar e incluso obtener privilegios de superusuario (root) en el dispositivo.

Una de estas vulnerabilidades está relacionada con el servicio de DNS, y es que se podrían realizar peticiones DNS al puerto 8291, y un atacante remoto no autenticado, podría realizar un envenenamiento de caché DNS en el dispositivo. Este fallo de seguridad tiene el identificador CVE-2019-3978. También existe otro fallo en los DNS del sistema operativo, y es que debido al manejo incorrecto de las respuestas DNS, un atacante remoto a través de un servidor DNS comprometido, podría enviar peticiones maliciosas para envenenar la caché del router. Este fallo de seguridad tiene el identificador CVE-2019-3979.

La tercera vulnerabilidad encontrada está relacionada con las actualizaciones del propio RouterOS, y es que un atacante podría generar un paquete de actualización malicioso, y si un usuario lo instalase en el propio router, podría habilitar un terminal con privilegios de superusuario. Este fallo de seguridad tiene el identificador CVE-2019-3976. Por último, también se ha descubierto una falta de validación de paquetes de actualizaciones cuando el parámetro de autoactualizar está activado, esto permitiría que un atacante remoto pudiera hacer un «downgrade» al firmware del router, e instalar una versión antigua para explotar fallos de seguridad que se han encontrado (y corregido) con anterioridad. Se ha asignado el identificador CVE-2019-3977 para esta vulnerabilidad.

¿Qué versiones del firmware están afectadas?

Todos los firmwares RouterOS Stable con versiones 6.45.6 y anteriores están afectadas por estos fallos de seguridad encontrados, asimismo, las versiones RouterOS Long-term con versiones 6.44.5 y anteriores también son vulnerables a estos fallos de seguridad. Por lo tanto, si tienes una de estas versiones debes actualizar cuanto antes tu router para solucionar los fallos de seguridad.

¿Están disponibles nuevas versiones de RouterOS para solucionar estos fallos de seguridad?

Actualmente ya se encuentran disponibles las nuevas versiones del firmware RouterOS que solucionan estos cuatro fallos de seguridad graves que se han encontrado. Concretamente, si estás utilizando RouterOS Stable, la versión que debes instalar es la 6.45.7 o superior. Si estás utilizando la versión RouterOS Long-term, la versión que debes instalar es la 6.44.6 o superior.

No es la primera vez que el sistema operativo RouterOS de MikroTik se tiene que actualizar de urgencia por fallos de seguridad graves, donde un atacante remoto podría tomar el control total del dispostivo como superusuario. Es recomendable que sigáis todas las guías de seguridad de sus routers para mitigar en la medida de lo posible todos estos fallos, y estar alerta con las nuevas actualizaciones que lancen para solucionar todos estos fallos de seguridad.