Desinstala WinRAR cuanto antes: este fallo de seguridad ha estado poniendo en peligro tu PC desde hace 19 años

Escrito por Rubén Velasco

WinRAR es, probablemente, el compresor y descompresor de archivos más conocido utilizado por más de 500 millones de usuarios en todo el mundo. Sin embargo, aunque siempre nos hayamos preocupado de tener esta herramienta actualizada a sus versiones más recientes, de nada ha servido para proteger nuestra seguridad, y es que una vulnerabilidad lleva poniendo en peligro a todos los usuarios de este famoso compresor a causa de una vulnerabilidad de hace 19 años.

Los investigadores de seguridad de Check Point acaban de dar a conocer hace algunas horas un fallo de seguridad crítico en WinRAR que afecta a todas las versiones de este compresor de archivos lanzadas desde el año 2000. Esta vulnerabilidad reside desde hace 19 años en una librería muy antigua llamada “UNACEV2.DLL“, librería que desde entonces es utilizada por el compresor para poder descomprimir archivos en formato ACE, poniendo en peligro a todos los usuarios.

Los piratas informáticos pueden ocultar fácilmente un paquete ACE modificado como si fuese un archivo RAR dado que esta aplicación reconoce los archivos por su forma y contenido, no por su extensión. Cuando el usuario ejecuta este archivo, el fichero ACE explota la vulnerabilidad “Absolute Path Traversal” de la librería y finalmente consigue ejecutar código aleatorio en la memoria, copiando malware que se encuentra dentro del fichero comprimido en el sistema sin levantar sospechas.

Como se puede ver en el vídeo, el pirata informático no tiene que hacer nada más que convencer al usuario de que descargue y ejecute un archivo comprimido, algo muy sencillo si tenemos en cuenta la gran cantidad de archivos pirata que se distribuyen por la red a diario comprimidos, por lo que no podemos saber si esta vulnerabilidad ha sido explotada, o no, en la red.

Cómo protegernos de esta vulnerabilidad en WinRAR

La forma más obvia para protegernos de este grave fallo de seguridad es desinstalar WinRAR de nuestro sistema y optar por otro compresor de archivos, ya que en la red existen una gran cantidad de compresores alternativos muy superiores en prestaciones y características, como PeaZip o Bandizip, dos grandes alternativas gratuitas (y la primera, además, OpenSource) que nos permitirán trabajar con ficheros RAR y RAR5 sin ningún problema.

Si por alguna razón queremos seguir utilizando WinRAR en nuestro sistema, debemos tener en cuenta que la librería “UNACEV2.dll” lleva en esta aplicación desde el año 2000, aunque la compañía perdió el código fuente de esta en 2005 (por lo que no puede corregir dicha vulnerabilidad), por lo que todas las versiones que podemos encontrar hasta ahora son vulnerables, hasta la 5.70 beta 1, versión que finalmente elimina el soporte para el formato ACE y, por lo tanto, hace que deje de ser vulnerable.

Es innegable que los archivos comprimidos son muy útiles en el día a día, sobre todo para intercambiar varios archivos empaquetados en un solo fichero a través de Internet en lugar de hacernos descargar decenas de archivos pequeños. Sin embargo, dados este problema de seguridad al que nos está exponiendo WinRAR, lo mejor que podemos hacer para evitar caer en las garras de los piratas informáticos, es buscar una alternativa.

¿Usas WinRAR? ¿Has actualizado a la beta 1 o cambiado de compresor para protegerte de esta vulnerabilidad?

Fuente > thehackernews