Los NAS de TerraMaster en peligro por un fallo de seguridad crítico

TerraMaster es un fabricante de servidores NAS bastante conocido en el mundo de los servidores NAS domésticos, este fabricante se caracteriza por proporcionar NAS bastante baratos y con unas especificaciones técnicas bastante interesantes. TerraMaster utiliza un sistema operativo propio para sus equipos, lógicamente este sistema operativo está basado en Linux, como ocurre con los NAS de QNAP, Synology o ASUSTOR. Unos investigadores de seguridad han descubierto vulnerabilidades de seguridad críticas en el sistema operativo, por lo tanto, si tienes un NAS de este fabricante, presta especial atención porque tus datos pueden estar en peligro.

En qué consiste este fallo de seguridad

Unos investigadores de seguridad han descubierto una serie de vulnerabilidades de seguridad críticas que podrían encadenarse para lograr ejecución remota de código no autenticado con privilegios de root. Esto significa que cualquier ciberdelincuente podría infectar nuestro servidor NAS y hacer cualquier acción con permisos de superusuario, por lo que es un grave fallo de seguridad que debes tener muy en cuenta.

El problema de seguridad se encuentra en el TOS (TerraMaster Operating System), este es el sistema operativo diseñado para los dispositivos de TerraMaster que permite a los usuarios gestionar el almacenamiento, los diferentes servicios, instalar aplicaciones multimedia, realizar copias de seguridad y muchas otras acciones que podemos hacer en un servidor NAS doméstico. Este fallo de seguridad se puede explotar con tan solo conociendo la dirección IP del servidor NAS, además, estos fallos se pueden encadenar para conseguir permisos de root, por lo que estaremos totalmente «vendidos» frente a un posible ataque.

El primer fallo de seguridad está catalogado como CVE-2022-24990, este fallo de seguridad consiste en fuga de información de un componente llamado «webNASIPS» que es básicamente la exposición de la versión de firmware dels sitema operativo, la dirección IP y la dirección MAC de la interfaz de la puerta de enlace predeterminada y la clave de administrador hasheada. El segundo fallo está catalogado como CVE-2022-24989, este fallo consiste en una inyección de comandos en un módulo de PHP llamado «createRAID». Ambos fallos de seguridad se pueden utilizar para enviar un comando para ejecución de código remoto.

Recientemente los usuarios de TerraMaster se han visto afectados por un ataque de ransomware, tal y como ocurrió hace unas semanas con ASUSTOR y hace unos meses con QNAP. Se cree que los ciberdelincuentes aprovecharon esta vulnerabilidad con el objetivo de infectar los servidores NAS y pedir un rescate.

A qué versión afecta este fallo

El equipo de desarrollo de TerraMaster ha lanzado una actualización importante que es la 4.2.30 para corregir este fallo de seguridad tan grave, además, se lanzó hace justo una semana, por lo que es muy recomendable que inicies una actualización del sistema operativo cuanto antes, porque todas las versiones anteriores a la 4.2.30 están afectadas por este fallo tan grave.

Esta nueva versión del sistema operativo también pone fin al ransomware DeadBolt, un ransomware que ha afectado a los servidores NAS de la compañía, cifrando todos los datos de los usuarios, y perdiendo una gran cantidad de información. Si no has instalado aún la última versión de TOS 4.2.30, os recomendamos acceder a la web oficial de TerraMaster donde vais a poder encontrar todos los detalles.

¡Sé el primero en comentar!