Configura tu router Cisco IOS con Movistar FTTH triple-play (Internet, Movistar TV y VoIP)

Escrito por Sergio De Luz
Banda Ancha

Para configurar el denominado triple-play del operador Movistar bajo fibra óptica hasta el hogar (Internet, Movistar TV a través del decodificador y desde cualquier ordenador vía VLC y también VoIP) es necesario configurar la denominada triple-VLAN, ya que de lo contrario no se podría visualizar Movistar TV desde un ordenador, únicamente desde el decodificador a través de un determinado puerto Ethernet del router, y además habría que aplicar una configuración específica manualmente.

Actualmente los routers Mikrotik y Ubiquiti tienen esta funcionalidad, asimismo el firmware OpenWRT que es compatible con un gran número de routers del mercado también lo es. En este artículo os vamos a explicar cómo configurar la triple-vlan para Movistar FTTH con cualquier router Cisco con IOS.

cisco_logo_apertura

Lo primero que tenemos que hacer es conectar el cable de red desde la ONT hasta un puerto del router, nosotros hemos elegido la interfaz FastEthernet 4, a continuación debemos entrar en modo privilegiado:

enable

Y posteriormente en modo de configuración global:

configure terminal

Una vez hecho esto, ya estamos listos para empezar con la configuración, debéis fijaros bien en cada comando ya que no hemos puesto las direcciones IP reales, está perfectamente indicado en mayúscula.

Configuración de un router Cisco IOS

Internet

Supongamos que la interfaz de Internet es la FastEthernet4 y la LAN nuestra es la bvi1 (que podría ser un puerto enrutado o una interfaz vlan, daría igual).

interface FastEthernet4
 description WAN
 no ip address
 duplex auto
 speed auto
 no cdp enable
!
dialer-list 1 protocol ip permit
!
interface FastEthernet4.6
 encapsulation dot1Q 6
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!

interface Dialer0
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname adslppp@telefonicanetpa
 ppp chap password 0 adslppp
 ppp ipcp dns accept
 ppp ipcp route default
 max-reserved-bandwidth 100
!

Configuración NAT

Debemos denegar los destinos de Movistar TV y telefonía IP:

access-list INTERNET deny   pim any any
access-list INTERNET deny   igmp any any
access-list INTERNET deny   ip any 10.0.0.0 0.255.255.255
access-list INTERNET deny   ip any 172.16.0.0 0.15.255.255
access-list INTERNET permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
ip nat inside source list INTERNET interface Dialer0 overload

Configuración de la LAN y Wi-Fi

bridge irb
bridge 1 route ip
dot11 ssid Milhouse
 vlan 1
 authentication open
 authentication key-management wpa
 guest-mode
 wpa-psk ascii 0 doyoulikemykey
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool DIRECCIONES
   network 192.168.1.0 255.255.255.0
   option 240 ascii ":::::239.0.2.10:22222:v6.0:239.0.2.30:22222"
   default-router 192.168.1.1
   dns-server 172.26.23.3
!
ip name-server 172.26.23.3
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip dns server
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid Milhouse
 !
 speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
 packet retries 128 drop-packet
 station-role root
 rts threshold 2312
 world-mode dot11d country ES both
 no cdp enable
!
interface Dot11Radio0.1
 description Milhouse Open
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
! El puerto Lan fisico o los que tengas
interface FastEthernet0
 description Test
 no cdp enable
 spanning-tree portfast
!
interface BVI1
 description wifiandethernet
 ip address 192.168.1.1 255.255.255.0
 ip pim sparse-dense-mode
 ip nat inside
 ip virtual-reassembly
 ip igmp helper-address 10.64.0.1
 ip igmp helper-address udl FastEthernet4.2
 ip igmp proxy-service
!

Configuración Movistar TV

Importante los comandos IGMP, el helper-address es la IP del gateway de Movistar TV (depende de tu configuración que puedes sacar con la web de Noltari).

interface BVI1
  description wifiandethernet
  ip address 192.168.1.1 255.255.255.0
  ip pim sparse-dense-mode
  ip nat inside
  ip virtual-reassembly
  ip igmp helper-address !!!!GATEWAY DE TU DECO!!!!!
  ip igmp helper-address udl FastEthernet4.2
  ip igmp proxy-service</pre>
 
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
 passive-interface default
 no passive-interface fa4.2
no passive-interface fa4.3
!
interface FastEthernet4.2
  description IPTV
  encapsulation dot1Q 2
  ip address !!!IP Y MASCARA DE TU DECO!!!
  ip pim sparse-dense-mode
  ip nat outside
  ip virtual-reassembly
  ip igmp unidirectional-link
ip access-list extended IPTV
 permit ip any 172.16.0.0 0.15.255.255
ip nat inside source list IPTV interface FastEthernet4.2 overload
ip pim rp-address !!!!GATEWAY DE TU DECO!!!!!

Configuración Telefonía IP

En caso de que el servidor de registro cambie hay que cambiar la IP de la ACL.

interface FastEthernet4.3
 description TOIP
 encapsulation dot1Q 3
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 no cdp enable
!
ip access-list extended VOIP
 permit ip any host 10.31.255.134
!
ip nat inside source list VOIP interface FastEthernet4.3 overload
!

Verificación de que el sistema funciona correctamente

Comprobacion de que funciona la IPTV de Movistar, el siguiente comando dirá a qué IP se suscribe el decodificador o los PCs.

show ip igmp join group

foto_movistar_ftth

Cuando el decodificador pregunta sobre las opciones del menú:

redeszone#sh ip nat tran | inc IP_DECO
udp IP_DECO:1798    192.168.1.66:1798     172.26.23.3:53        172.26.23.3:53
udp IP_DECO:30968   192.168.1.66:30968    172.26.23.3:53        172.26.23.3:53
udp IP_DECO:60768   192.168.1.66:60768    172.26.23.3:53        172.26.23.3:53

Cuando se realiza una llamada de teléfono:

redeszone#sh ip nat trans | inc 10.31.255.134
udp 10.23.209.14:1029     192.168.1.200:5060    10.31.255.134:5060    10.31.255.134:5060

Las rutas RIP de IPTV que se crean:

redeszone#sh ip route rip
172.26.0.0/16 is variably subnetted, 9 subnets, 5 masks
R       172.26.22.56/29 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.22.0/26 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.23.0/27 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.23.5/32 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.23.4/32 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.23.23/32 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.23.24/32 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.23.30/32 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
R       172.26.80.0/21 [120/2] via IP_GATEWAY, 00:00:22, FastEthernet4.2
10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
R       10.31.255.128/27 [120/3] via 10.23.192.1, 00:00:27, FastEthernet4.3

La configuración VoIP es dinámica, sin embargo la configuración de Movistar TV es estática. En la siguiente captura de pantalla se puede comprobar cómo

Otra información

Para conseguir hacer funcionar el sistema, debemos tener en cuenta lo siguiente, tanto para la VoIP como para Movistar TV:

voip proxy register 10.31.255.134  ! Necesita hacer NAT a fa4.3
movistartv dns server 172.26.23.3  ! Necesita hacer NAT a fa4.2

En este enlace podéis descargar un archivo TXT con toda la configuración realizada en el router.

Agradecemos a nuestro compañero Luis las pruebas realizadas y toda la configuración aportada para la realización de este manual.


Continúa leyendo
  • luicson

    Me alegro ver algo de Cisco por aqui!!! =)

  • luicson

    Buen aporte Sergio!

    por cierto, que usas para la telefonia? UN softphone sin mas?

    • Lo ha hecho Luis, yo no tengo Movistar FTTH de momento.

    • luis

      Yo ni siquiera uso un cisco para conectarme a internet el tutorial lo hice solo como un reto personal, nadie lo había hecho y parte de la culpa es porque la gente no sabe como lo tiene configurado movistar.
      Está probado con un softphone y la television con el decodificador de movistar y con el vlc.

      • luicson

        entiendo que eres luismg? xD

        curisidad..pq utilizas un bridge en vez de int vlan?

        • luis

          Para que el wifi pueda ver Movistart TV igual que los que van por cable. Para que compartan direccionamiento y porque el que me dejó el router ya lo tenía asi 🙂

          • luicson

            ok gracias. Entonces creo q se podria hacer igualmente con int vlan.

            saludos

  • jantonio

    Hola gracias por el tutorial, pero la TV no funciona, he reparasado la config y creo que lo tengo todo bien pero no consigo que funcione la TV, lo he probrado en un Cisco 1921
    Un saludo

    • jose antonio

      hola jantonio lograste hacer funcionar cisco 1921 con fibra movistar , yo me e hecho con un cisco 1921 pero por mas que pruebo configuraciones no logró hacer que me funcione . gracias

      • jose antonio martin

        si al final conseguí hacerlo funcionar ,
        levante interfaces y listo (fallo de novato)
        gracias y saludos

  • luis

    La tv funciona perfectamente, la configuración no es teórica, está probada, cuelga la running config completa en pastebin, cuelga también el show ip route rip, show ip igmp group cuando cambias de canal en el deco
    y supongo que habras puesto la ip mascara gateway de la TV y el dns bien.

    Conozco a gente que ha adaptado esta configuracion a ADSL con movistar tv y le funciona pertectamente.

    Un saludo

    • Cevipower

      Luis,

      a mi me pasa lo mismo compañero, he seguido la guia, incluso sin configurar VOIP para hacerlo mas simple… y no hay webs.

  • Cevipower

    La verdad es que esta currado.

    Es de agradecer este tipo de aportes para los amantes de Cisco.

    La parte de Internet esta clara, y excepto que yo uso un 881g y el throughput de paquetes solo me deja una descarga de máx 50 Mb. la estabilidad comparada con el Comtrend es diferencial.

    Lo que me trae de cabeza es la parte de IPTV; no consigo hacerla funcionar por mas que investigo; y según leo este “guiaburros” y el archivo TXT del compañero Luis, encuentro diferencias entre las config que hacen que me pierda.

    Alguno me puede pasar una config con interface vlan en lugar de bridge y que este funcionando? (uso imagenio nuevo)

    Saludos de antemano.

  • luis

    interface vlan 1
    description wifiandethernet
    ip address 192.168.1.1 255.255.255.0
    ip pim sparse-dense-mode
    ip nat inside
    ip virtual-reassembly
    ip igmp helper-address !!!!GATEWAY DE TU DECO!!!!!
    ip igmp helper-address udl FastEthernet4.2
    ip igmp proxy-service

    no megas ningun comando bridge en ningún sitio y a funcionar.

  • luis

    es más me ofrezco a ayudarte via skype o hangouts o lo que quieras si no consigues hacerlo funcionar.

    un saludo

    • Cevipower

      Muchas gracias Luis,
      La verdad es que esa parte de config la tengo igual, para mi que tiene que ver con Nat y Rip.

      De todas maneras puedes contactarme con skipe si te viene bien y le damos “zapatilla”

      Muchísimas gracias.

      • luis

        Claro que si ¿como contacto contigo?

        • Cevipower

          luis, contacta conmigo por email y concretamos si te parece.
          El Mail es: ripichu@hotmail.com

          Muchas gracias de nuevo.

          • cevipower

            Luis,

            eres una maquina, muchas gracias por todo.
            A ver si posteas lo que me pasaba de multicast y le sirve a algún otro.

            Mil gracias de nuevo.

      • Merlin

        Hola luis, como me puedo contactar contigo.. cual es tu skype tengo unas dudas referente a movistar… gracias de antemano!

    • Eddie _

      Luis,

      has detectado el problema en las grabaciones con un cisco?

  • Tito

    Hola Luis,

    Ante todo muchas gracias por compartir esto, has sido de gran ayuda.

    He configurado mi router algo diferente a como lo has hecho tu debido a que mi router es un cisco, pero es un c2651XM y la configuración tal y como la compartiste no me valia (entre otras cosas porque solo tiene 2 puertos ethernet y no tiene wifi) en cualquier caso, me he sorprendido a mi mismo en que después de hacer los cambios que me parecieron oportunos (mis conocimientos sobre el tema son de autodidacta) funcionó a la primera. Al menos lo que se refiere al acceso a internet, la TV y la VoIP aun no he probado.

    Sin embargo, al hacer el test de velocidad en subida me da los 10Mb pero en bajada solo 16Mb (de !00 que debería, o al menos eso dice el test cuando utilizo el “jugetito” que te deja Telefonica a modo de router).

    En fin, se me acaban las ideas y no se por donde seguir.

    Gracias de nuevo por todo

  • luis

    Hola TIto, ese router debería dar mucho más, ¿tienes cef habilitado? ip cef es el comando, quiza el problema es que esté gastando cpu para enrutar los paquetes cuando podría estar enrutando el primero y conmutando los demas.
    ip tcp adjust-mss 1452 este comando solo debe de estar en el puerto wan de internet (dialer 0 o 1) si no hace gastar bastante cpu.

    Mira que no tengas la cpu alta, show proc cpu history. Ya que eso si que degrada la transferencia. Una mala configuración del NAT también puede ahogar el router, hay tantas variables…
    mira si con lo que te he puesto arriba te mejoran las transferencias. Te tiene que dar cerca de 85 Mb con la tv puesta.

    un saludo

    • maku

      hola luis tengo un problema tengo un ruuter cisco adsl y no puedo configurarlo para movistar chile , ojala me puedas ayudar
      😀 este es mi correo cualquier cosa xxxxxxx@gmail.com

  • Tito

    Hola Luis, gracias por tu ayuda.

    Hoy he tenido un ratillo y me he puesto a trastear de nuevo. A ver, si, CEF está habilitado y ip tcp adjust.mss 1452 está configurado solo para el interface dialer. Hoy he vuelto hacer la prueba de velocidad y me ha dado 13 MB de bajada (voy perdiendo megas por el camino al parecer, jajaja). Durante el test de velocidad en bajada la cpu, efectivamente, llega al 100%, mientras que en subida tan solo llega al 70%. Mal asuntillo.

    Antes de hacer el test hice algún cambio en la configuración del router, concretamente en el routing. Tenia dudas sobre la configuración de rip, ya que la configuración que colgaste en esta página difiere del archivo de texto del link que publicaste al final (el archivo de texto no tiene las líneas passive-interface default, no passive-interface fa0/1.2 y no passive-interface fa0/1.3). Como no ando muy puesto en los protocolos de enrutamiento, en un principio configuré una ruta estática: ip route 0.0.0.0 0.0.0.0 dialer 6, y funcionó, y me daba 16 Mb de bajada. Pero tampoco funcionaba imagenio. Así que esta vez probé con rip, y me ha dado los 13 Mb en bajada que he mencionado antes… y sigue sin funcionar imagenio. En subida no ha habido cambios significativos y el enrutamiento no creo que sea el problema de la velocidad, aunque posiblemente si de que no se vea Imagenio.

    Te dejo aqui la configuración de mi router por si tienes la amabilidad de echarle un vistazo a ver si ves donde estoy metiendo la pata.

    • Anónimo

      hello, te falta
      interface FastEthernet0/0
      ip igmp helper-address IPDELGATEWAYDEIMAGENIO

      otro error el dns del deco o lo tienes estatico en el deco o lo tienes que tener en tu pool de dhcp (no te preocupes que resuelve cualquier dominio de internet)

      no ip dhcp pool DIRECCIONES
      ip dhcp pool DIRECCIONES
      network 192.168.1.0 255.255.255.0
      option 240 ascii “:::::239.0.2.10:22222:v6.0:239.0.2.30:22222”
      default-router 192.168.1.1
      dns-server 172.26.23.3
      !

      Por lo demás esta bastante bien, quiza puedes quitar el ip dhcp smart-relay.
      Fijate show int fa0/0 (que el duplex quede a full y la velocidad a 100)

      Cuentame como lo ves ahora.
      un saludo

      • Anónimo

        Muchas gracias, ya funciona imagenio, ‘sos’ un crak. Pero la velocidad sigue baja, ahora no me llega a 15 Mb…. he mirado lo que me dijiste, he configurado tanto en el router como en el switch con full-100 a piñon fijo, pero nada, no salimos de los 15-16 Mb en bajada

        • Anónimo

          ¿tienes un switch entre la ONT y el router?
          fijate que todo este a 100 full, y te diré en cisco (y en otros fabricantes) si fuerzas en un lado y negocias en otro el resultado es 100 half.
          Lo mejor es todo auto y cable recto. Mira en auto todo si haces show int fa0 a ver si pone 100 full negociado. Eso es primordial.
          Una vez eso miramos porque sube la cpu son show proc mem sorted y show proc cpu history.
          El adjuntar el fichero de la config ha sido fundamental para detectar el error.

          un saludo

  • Johnny

    Hola, esta genial!
    Una pregunta. Para dejar el router cisco en modo bridge/monpuesto, que configuración usariamos?
    Seria el Firewall detrás del router el que iniciaria la session PPPoe.
    Gracias

    Un saludo

    • luis

      personalmente no lo dejaría en bridge porque el nat dejará de funcionar y con ello todo fallará menos internet.

      • Bellower

        Hola Luis, tengo un servicio de IPTV de Movistar pero no soy de España, como puedo ubicarte por skype para que pudieras guiarme con esta configuracion basado en lo que ofrece Movistar en mi pais? agradezco tu ayuda. Saludos

      • Enric

        Hola compañeros yo tambien e seguido todo el manual pero tengo algun problema ya que no me funciona.

        Tengo un cisco 1841 y un 1801, actualmente tengo la fibra de movistar sin television.

        Mi problema es que cuando configuro el fastethernet4.6 yo uso 0.6 ya que el fastethernet que tengo conectado a la ONT es el 0/0

        el comando pppoe-client dial-pool-number 1 no me lo acepta y supongo que es por eso que cuando conecto el cisco a la ont y el pc al cisco no puedo navegar.

        Si alguien tiene alguna idea se lo agradecere.Saludos y sinceramente un gran aporte este manual.

  • Lucas

    Hola,

    Muy bueno el post. Sin embargo, no consigo abrir puertos.

    He probado con sin éxito:

    ip nat inside source static tcp 172.26.0.2 80 interface Dialer6 37080

    ip nat inside source static tcp 172.26.0.2 80 interface GigabitEthernet0/1.6 37080

    ¿Qué hago mal?.

    Gracias.

    • luis

      no tienes que abrir ningun puerto en el tema de telefonia ip ni de video.

  • Ángel

    Hola @LUIS,

    Tengo una duda, yo en casa tengo enchufados un par de teléfonos analógicos al vg8050, para seguir funcionando con estos teléfonos, ¿se podría dejar enchufado el router vg8050 al cisco?, repito solo para dar servicio a los teléfonos analógicos, para ello supongo que en el ethernet donde enchufe el vg8050 sólo pasaría la vlan de voz.

    Muchas gracias y un saludo.

    • Ángel

      Hola compañeros,

      Tengo un 1841 y he configurado correctamente internet, pero tengo algún problemilla con la televisión, alguien que lo haya configurado me podría pasar el modelo y versión de IOS que usa y un running-config?

      Muchas gracias.

      • ignacio

        Que modelo de router de cisco aprovecha mejor los 300 mb de la fibra optica

        • Eddie

          Yo tengo un 3825 y va de lujo….

          • Oscar

            Hola, me podrias pasar la config del 3825 porfa?
            Llevo 3 dias y cuando veo la pantalla de publicidad no va el menu del deco, y cuando va el menu, no me va la imagen.

          • Eddie _

            Es la misma que esta publicada.

  • José

    Hola he visto que con el router Telnet TriplewaveSTB ya ponen la ONT en el router bueno yo gogleando he llegado a esta configuración hw creo que se llama para poner una targeta wan de fibra por ehwic un EHWIC-1GE-SFP-CU y dentro el Transciever que es la pieza de FTTH que ha de ser compatible con operador creo que es el GLC-BX40-U-I según indica Movistar con las prestaciones del router Telnet de arriba.

  • bootpc
    • Eddie

      Pues no tengo permisos para ver la config.

      HE DETECTADO UN PROBLEMA…. LAS GRABACIONES.

      Alguien las puede reproducir sin problemas??

      Gracias.

  • Eddie

    Hola,

    una vez probado TODO y verlo funcionar (INTERNET, IPTV, VOIP) he detectado un problemilla…. LAS GRABACIONES.

    Alguien las puede reproducir sin problemas??

    Gracias.

    • Eddie _

      Alguien?

  • Jorge

    Hola!
    He seguido la guía pero no consigo hacer funcionar el deco de imagenio. Luis, ¿podrías echarme una mano?

    Using 4169 out of 262136 bytes
    !
    ! Last configuration change at 03:39:58 UTC Tue Feb 9 2016
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    no ip source-route
    !
    !
    !
    ip dhcp excluded-address 172.16.12.193
    !
    ip dhcp pool USUARIOS
    import all
    network 172.16.11.192 255.255.255.192
    default-router 172.16.11.254
    dns-server 172.16.10.11 172.16.10.12
    domain-name pheros.local
    !
    ip dhcp pool MULTIMEDIA
    import all
    network 172.16.12.192 255.255.255.192
    default-router 172.16.12.254
    dns-server 172.26.23.3
    domain-name pheros.local
    option 240 ascii “:::::239.0.2.10:22222:v6.0:239.0.2.30:22222”
    !
    !
    !
    ip multicast-routing
    ip cef
    no ip igmp snooping
    no ipv6 cef
    !
    !
    multilink bundle-name authenticated
    !
    !
    license udi pid C892FSP-K9 sn FCZ1807C3A8
    !
    !
    vtp mode transparent
    !
    !
    vlan 20
    name CLIENTE
    !
    vlan 2001-2002,3000-3001
    !
    !
    !
    !
    !
    interface GigabitEthernet0
    switchport trunk native vlan 3000
    switchport mode trunk
    no ip address
    !
    interface GigabitEthernet1
    switchport mode trunk
    no ip address
    !
    interface GigabitEthernet2
    no ip address
    !
    interface GigabitEthernet3
    no ip address
    !
    interface GigabitEthernet4
    no ip address
    !
    interface GigabitEthernet5
    no ip address
    !
    interface GigabitEthernet6
    no ip address
    !
    interface GigabitEthernet7
    no ip address
    !
    interface GigabitEthernet8
    description ONT-Uplink
    no ip address
    duplex auto
    speed auto
    no cdp enable
    !
    interface GigabitEthernet8.2
    description IPTV
    encapsulation dot1Q 2
    ip address 10.133.229.136 255.128.0.0
    ip pim sparse-dense-mode
    ip nat outside
    ip virtual-reassembly in
    ip igmp unidirectional-link
    ip igmp proxy-service
    no cdp enable
    !
    interface GigabitEthernet8.3
    encapsulation dot1Q 3
    ip address dhcp
    ip nat outside
    ip virtual-reassembly in
    no cdp enable
    !
    interface GigabitEthernet8.6
    encapsulation dot1Q 6
    ip nat outside
    ip virtual-reassembly in
    pppoe enable group global
    pppoe-client dial-pool-number 1
    no cdp enable
    !
    interface GigabitEthernet9
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Vlan1
    no ip address
    !
    interface Vlan2001
    ip address 172.16.11.254 255.255.255.192
    ip pim sparse-dense-mode
    ip nat inside
    ip virtual-reassembly in
    ip igmp helper-address 10.128.0.1
    ip igmp helper-address udl GigabitEthernet8.2
    ip igmp proxy-service
    !
    interface Vlan2002
    description MULTIMEDIA
    ip address 172.16.12.254 255.255.255.192
    ip pim sparse-dense-mode
    ip nat inside
    ip virtual-reassembly in
    ip igmp helper-address 10.128.0.1
    ip igmp helper-address udl GigabitEthernet8.2
    ip igmp proxy-service
    !
    interface Vlan3000
    ip address 172.16.254.254 255.255.255.240
    ip nat inside
    ip virtual-reassembly in
    !
    interface Vlan3001
    ip address 172.16.10.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    interface Dialer0
    mtu 1492
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname adslppp@telefonicanetpa
    ppp chap password 0 adslppp
    ppp ipcp dns accept
    ppp ipcp route default
    no cdp enable
    !
    router rip
    version 2
    passive-interface default
    no passive-interface GigabitEthernet8.2
    no passive-interface GigabitEthernet8.3
    network 10.0.0.0
    network 172.26.0.0
    no auto-summary
    !
    no ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    ip pim rp-address 10.128.0.1
    ip nat inside source route-map INET interface Dialer0 overload
    ip nat inside source route-map IPTV interface GigabitEthernet8.2 overload
    ip nat inside source route-map VoIP interface GigabitEthernet8.3 overload
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    access-list 10 permit any
    dialer-list 1 protocol ip permit
    !
    route-map INET permit 10
    match ip address 10
    match interface Dialer0
    !
    route-map IPTV permit 10
    match ip address 10
    match interface GigabitEthernet8.2
    !
    route-map VoIP permit 10
    match ip address 10
    match interface GigabitEthernet8.3
    !
    !
    control-plane
    !
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    login
    transport input all
    !
    scheduler allocate 20000 1000
    !
    end

  • xavi

    Una pregunta sobre el voip en los routers caso 1841 si conecto un teléfono ip cisco 7961 por ejemplo funcionaria con el voip de movistar o hay que hacer algo mas ¿?

    Saludos y cuando me llegue el router probare la configuración a ver si aguanta los 300 mb de Fibra.

    • xavifer

      Sabeis si el router 1841 o 2621xm soporta fibra 300Mb ¿? alguien que me pueda confirmarlo. Muchas gracias y saludos

      • Eddie _

        No, no tiene suficiente throughput. Necesitas un router superior o no pasaras de les 20Mbps. Ademas piensa que sus puertos son FastEthernet para empezar (100Mb).

    • Eddie _

      Hay que cargarme un firmware especial para SIP. Te lo puedes bajar desde la web de cisco.

  • Alberto Fernandez

    Hola Luis,
    La configuración funciona perfectamente excepto en una cosa: no se pueden ver las emisiones de TV de los últimos 7 días. Yo creo que tiene que ver también con el problema que alguno ha comentado por aquí de la imposibilidad de ver las grabaciones. No se si tu o alguien tiene ya una solución o alguna idea de como resolverse.

    Gracias

    • Eddie _

      Tengo el mismo problema que tu y de momento nadie me ha podido dar una solución.

      Sigo impaciente a la espera.

      Se agradece.

  • Vincent

    Hi Sergio, Thanks for you configuration and explanation, in France we have pretty the same network topology, i have adapted your config to mine but i stil did not get IPTV to work, would you help me ? i think i have an IGMP issue

    Thanks Vincent

  • Fran Saez

    Alguna persona capaz de hacerlo funcionar? no me importa pagarle las horas necesarias como sea necesario. gracias!

  • Eddie _

    Hola

Últimos análisis

Valoración RZ
10
Valoración RZ
7
Valoración RZ
9
Valoración RZ
10
Valoración RZ
8
Valoración RZ
10
Valoración RZ
9
Valoración RZ
9
Valoración RZ
10